TESCS2 : Versions des plugins

De Wiwiki
Sauter à la navigation Sauter à la recherche


Message :

File Knights.esp is a higher version than this EXE can load.

ou tout autre nom de plugin que Knights.esp.


Explication : Lorsque l'on tente d'ouvrir le mod officiel Knight of the nines dans le TESCS2, on obtient le message ci-dessus.

Cela se produit pour tous les mods produits par Bethesda depuis le plugin officiel d'Oblivion.

En effet la version du pluggin n'est pas celle du jeu d'origine, et est incompatible avec le TESCS2 fourni par Bethesda pour éditer des mods personnels.

Tels qu'ils sont distribués, les fichiers .ESP des mods officiels, crées après le patch (officiel), ne peuvent pas être chargés dans le Construction Set.

C'est le cas également avec Knights.esp.

Solutions :

Trois solutions possibles :

Solution éditeur Hexa

  1. Ouvrez une copie du .ESP dans un éditeur Hexadécimal (comme Ultra-Edit, EditHexa...)
  2. Sur la deuxième ligne (offsets 18H to 1DH) modifiez 0C 00 00 00 80 3F par 0C 00 CD CC 4C 3F.

Cela permet au mod d'être chargé dans le Construction Set, et permet aussi (apparemment) de permettre son utilisation avec Oblivion non patché.

Les plugins plus anciens n'ont pas besoin d'être modifiés, et devraient fonctionner sans ajustement.


Solution TES4 plugin utility ou TES4Gecko

Attention : l'outil TES4 plugin utility est maintenant remplacé par son successeur TES4Gecko. Le mode d'emploi est identique pour la manipulation des versions de plugins.

Si vous n'avez pas l'outil TES4 plugin utility, consultez l'article TESCS2 : TES4 Plugin Utility pour l'installation et le mode d'emploi.

  1. Cliquer sur [Set Directory], et choisir le dossier data où se trouve l'ESP à modifier
  2. Cliquer sur [Edit Description] : cela permet de sélectionner un ESP du mod, puis cliquer sur [ouvrir]
  3. Sur la fenêtre suivante, cliquer sur [update]

L'ESP a maintenant la bonne entête et peut s'ouvrir dans le TESCS2.

Solution mise à jour du TESCS

C'est la solution idéale. Je laisse en place les deux solutions précédentes qui pourraient servir à nouveau, si Bethesda fait à nouveau évoluer ses plugins sans donner de nouvelle version du TESCS2.

Depuis l'apparition de cette incompatibilité des mods avec le TESCS version 0.8, de nouvelles versions du TESCS ont été publiées par BETHESDA. Téléchargez donc la dernière version 1.2 et installez là. Tous les mods antérieurs sont ainsi chargeables.